YouTube videos covering submenus

Depending on the design of your portal, you may run into some issues if you embed a YouTube video - in some browsers (IE and Chrome mostly) the video will cover your submenus.
This issue stems from a missing parameter that YouTube doesn´t deliver - there is, so far, no permanent solution but, of course, there is a workaround in a few simple steps:
  1. go to Youtube and look up the video that you want to embed
    • click on embed but choose the option to use the old embedding modus, this will give you the following code (I am using a SITEFORUM video as example)
    • <object width="560" height="315"><param name="movie" value="http://www.youtube.com/v/bF6s44K-HDc?version=3&amp;hl=de_DE"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/bF6s44K-HDc?version=3&amp;hl=de_DE" type="application/x-shockwave-flash" width="560" height="315" allowscriptaccess="always" allowfullscreen="true"></embed></object>
  2. you have to add the following parameter into this code: <param name="wmode" value="transparent"> and also call the parameter:
    • <object width="560" height="315"><param name="movie" value="http://www.youtube.com/v/bF6s44K-HDc?version=3&amp;hl=de_DE"></param><param name="wmode" value="transparent"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/bF6s44K-HDc?version=3&amp;hl=de_DE" type="application/x-shockwave-flash" width="560" height="315" wmode="transparent" allowscriptaccess="always" allowfullscreen="true"></embed></object>
  3. You can now paste the modified code into the source code of the long description of your story and the menu will now appear above the video.